Ich besitze seit längerer Zeit einen Sony Vaio VGN SR21M/S.

Darauf nutze ich nun mittlerweile seit einigen Tagen Ubuntu 11.04 Alpha 3.
Ubuntu erkennt glücklicherweise schon seit einigen Versionen meinen Laptop nahezu perfekt. Die FN-Tasten für Lautstärke und Bildschirmhelligkeit funktionieren und auch Hardwäremässig macht es keine Zicken. Das alles noch zudem ohne einen proprietären Treiber nutzen zu müssen.

Einzig mit den Suspend Modi, also Suspend to Disk (Ruhezustand) und Suspend to Ram (Bereitschaft) hatte ich schon immer Probleme. Der Laptop fährt zwar recht zügig in den gewünschten Modus, wenn man dann aber seine Arbeit fortsetzen will, startet der Laptop komplett neu. Es schien so, als ob er vergessen hatte, dass er im Suspend Modus war.


Unter anderem auch im Ubuntusers Forum stieß ich dann auf die gleichen Berichte, auch mit anderen Sony Laptops.
Nach ewiger suche, fand ich in einem Englischem Forum dann endlich die Lösung dafür.

Gebt die nachfolgenden Befehle im Terminal ein:

Ihr müsst die grub Konfigurationsdatei in /etc/default/grub bearbeiten, dazu:
sudo nano /etc/default/grub
Hier sollte ihr eine Zeile, GRUB_CMDLINE_DEFAULT_LINUX finden.
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Hinter dem letztem Eintrag vor dem abschließendem " , in diesem Fall also nach splash, solltet ihr folgendes hinzufügen
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs"
Die Option acpi_sleep=nonvs, sorgt dafür, dass die Suspend Modi ordnungsgemäß funktionieren.

Anschließend die Datei speichern, und ein update-grub im Terminal ausführen.

Das setzen dieser Option, sollte unter so gut wie jeden Linux Distribution und auch mit anderen Sony Laptops funktionieren. Unter anderem habe ich es auch bei openSUSE ausprobiert, wo es ebenfalls hervorragend klappte.

Ich hoffe das hilft jemandem da draußen :-)

6 Comments